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Using Microsoft Visual C++ .Net 2003
Objective
These notes are designed to provide information about using the Microsoft Visual C++ .Net integrated development environment (IDE) that will be used in this course.  These first part of these notes provide basic information to get you started using the IDE for simple programming.  The remainder of these notes provides information that will allow you to solve future problems when you get mysterious errors while using the IDE.

Computer accounts
You should be able to use the computers in the lab with the same user name and password that you use for access to other computers on campus.  If you have not yet activated your campus user account or if you have not used it for over six months, you will have to reactivate your account.  Download the instructions from the course web site from the link for “Accounts and Network Drives.”
Background
Students are assumed to be generally familiar with the typical operating system on a graphical user interface (GUI) such as Microsoft Windows.  You should be able to log on and log off to computers, start programs, and close programs.  You should be able to use various menu and editing commands to create, modify and save files.  This includes copying information from one file and pasting it to another file.  Although programming will be a new experience for most students, the act of entering a program into the computer is similar to the typing and editing of text in a word processing program.
Using Microsoft Visual C++ .Net 2003
Microsoft Visual C++ .Net 2003 is used by professional developers who work on complex projects.  This has an advantage for you in that you may encounter this compiler (or another version of it) in a future job.  However, it has a disadvantage: it is much more powerful that required for this course.  Seemingly simple omissions can lead to confusing errors.
Except for the last assignment, you will almost always have one C++ file for your program.  You want to use this file to write a program, compile it and execute it.  In complex applications, programmers may be working on several related projects, each of which may have several files.  To accommodate this Visual C++ provides “Solutions”, which can handle multiple projects, and projects which can use multiple files.  In almost all your programming you will not be concerned about the difference between the “solution” and the “project”.  However, you will have to be aware of the notion of the project and the C++ file that you are using for that project.  These are two separate entities and you have to define each one before you can proceed.  The way to do this is discussed in detail below.

You will get the fastest execution if you define your files on the hard drive (c:\temp) of the computer you are using.  However, such files may be erased between laboratory sessions as part of periodic clean-ups of hard drives.  In addition, you may not be able to use the same computer in all laboratory sessions.  You have to save your files to the network drive or a portable drive (floppy or USB) before leaving the lab.  You can access your files on the network drive from any other computer in the College, but you cannot access them from your home computer; use a floppy if you want to work at home.
Do not use floppy drives for compiling and executing your program.  Your floppy drive may not have enough room to hold all the files associated with a project and it will give very slow compilation and execution.  The detailed instructions below assume that you will use the local hard drive on the computer you are using to define your project and save your files during the lab session.  However, such files may be deleted periodically as part of normal computer maintenance.  You may want to use the network drive, because this saves your projects and files so that they can be accessed from any computer in the College.  However, the network drive can give slow execution times at times of high network traffic.

The computers in the laboratory use the Windows XP operating system.  There may be some slight differences between this system and the version of Windows with which you are familiar.  However, these differences are not significant in the operation of Visual C++.

Getting started
To get started, use your account number to log on to the computer.  (Press control-alt-delete to get the logon screen.)  Once you are logged on, follow the steps below to use Visual C++ .Net 2003.
1.
After you click on the Start button in the lower left hand corner, you will get another menu from which you have to select All programs.  This will give you the usual Windows program menu, from which you select Microsoft Visual Studio .Net 2003, which is about halfway down the left-hand column.
  This will give you a submenu from which you again select Microsoft Visual Studio .Net 2003.
2.
After you select this program, there will be a few seconds for the program to load.  You will then see a window with three frames.  The main frame, on the left side of the screen, may have one or more tabs at the top (just below the toolbar).
3.
Select New from the File menu; then select Project from the next menu.  This will open the New Project dialog box in which you will do the following.

a.
Look at the Project Types: menu on the top left.  If the Visual C++ Projects folder has a plus (+) sign on its left, click on this plus sign to reveal the subfolders under this folder.  If the subfolders are already shown (in which case the folder will have a minus sign to its left), proceed to step b.

b.
Select Win32 from the subfolders under the Visual C++ Projects folder in the Project Types: menu.  
c.
Select Win32 Console Project from the Templates: menu on the top right.
d.
Check the button in the lower left-hand corner of the dialog box.  If it says More click the button to reveal a third text box, called New Solution Name: and a line of text stating where your project will be stored.  If the button already says More, go on to the next step.

e.
Enter c:\temp in the Location: text box (the middle of the three text boxes at the bottom of the menu.)*
f.
Make sure that there is a check in the Create directory for Solution check box located to the right of the last text box on the dialog.
g.
Enter a name in the Name: text box.  (This is the first of three text boxes.)  Pick a simple name that describes your project.  For example you might pick exerciseOne, ex1, xOne, one, 1, or something similar as the name for the first exercise.  You may also want to use your name in the project name; for example I could call my first exercise larry1 or lsc1.  Notice that as you enter the name in this first text box, the name you enter is copied into the New Solution Name: text box.  In addition, the final line tells you the place where your project will be stored.
h.
Click the OK button to complete this step.
4.
You will now see the Win32 Application Wizard.  At this point you must click on Application Settings in the tab on the left of the menu.  This will give a new menu to the right.  At the top, the ratio button for Console Application should already be selected.  You must now place a check in the Empty project checkbox under the Additional options: portion of the menu.  Failure to do this step will lead to the creation of a set of files that are confusing to the beginning programmer.  Click the Finish button to return to the start page.
 5.
You should see the project name and a set of folders in the Solution Explorer frame on the top right side of the screen.  If you click on the Source Files folder you will see that there are no files there.  You have to add a file, as outlined below, to start programming.
6.
Open the Project menu and select Add New Item from that menu.  This will give you a dialog box in which you make the following selections.

a.
Select C++ File (cpp) from the Templates: menu on the top right.

b.
Enter a file name in the Name: text box.  This should be the same as your project name.  The IDE will automatically add a file suffix of .cpp to the name you enter.

c.
(optional)  Check the location of the file in the final text box.  This should be the directory that was created when you defined your project.

d.
Click Open to create your new file.
7.
You will be returned to the three-frame screen and you should see a blank area on the left of the screen on which you can write your program.  (There will be a tab at the top of this blank area with the name of your file.)  You should also see the source file identified in the Solution Explorer in the right-hand-side frame.  You are now ready to start programming!

8.
At this point you will enter your program.  This is done just as you would enter a program in a word processor, except that you only enter text without formatting.  If you are not sure what to enter here, ask your instructor what to do.  For the first Comp 106 class, you should have downloaded the instructions for exercise one.  Read those instructions and copy the code listing for version one of those instructions into the blank program file.

9.
After you have entered your program and corrected any typing errors, you are ready to compile, link, and execute your program.  Select Build solution from the Build menu.  The window below your program will show the progress of the compilation and linking steps.  (This process automatically saves your program file.  The file name listed in the tab will have an asterisk (*) after the name when the file has been changed since the last save.  This asterisk disappears when the file is saved.)
10.
Look at the Output window below your program listing.  You will see the steps as it compiles and links.  As the program compiles, errors and warnings will be listed.  A warning is an indication that something may be wrong with your program, but the compiler will still produce object code that can be linked.  The following message will appear at the end of the compilation and linking process If there are no errors:

Build: 1 succeeded, 0 failed, 0 skipped
Even if you get this message, you may still have warnings that you should check.  Use the scroll bar in the output window to find error and warning messages between the lines that say Compiling... and Linking...; an example of a warning message is shown below:

Compiling...

pex1.cpp

c:\temp\pex1\pex1\pex1.cpp(37) : warning C4700: local variable 'y' used without having been initialized

Linking...

If there are errors or warnings proceed to step 11.  If there are no errors or warnings, skip to step 13.
11,
If you click on the error message or warning a small thin pointer will appear on the program listing on the line with the error.  The error message should tell you what the error is, but sometimes the error messages are not clear.  Ask the instructror if you do not understand the change you must make to remove the error.

12.
After making the corrections you believe necessary to remove error and warning messages, return to step 9.

13.
Once you have successfully compiled and linked your program, with no warning messages, you can then select Start without debugging from the Debug menu to execute your program.

14.
A separate window that only displays text will open; this window will show the output from the program.  At the end of your program output, the IDE will print a message Press any key to continue on the screen.  After reviewing your results, press any key to start you next task.

15.
If you want to start a new project, go to step 3.  It is easier to keep the same project name and source file name and copy the new program into the old source file after saving the old source file under another name.  If you do this you will start at step 8.

The project and the source file
The project is the basic unit that is used to prepare an executable program.  A project may have several files.  For beginning programming courses, like Comp 106, most assignments will have only one source file and the distinction between the project and the source file can be confusing.  If you start a new project with a new source file as outlined above, there should be no confusion.  However, if you are writing more than one program (i.e., preparing more than one source file) for a given assignment, there are three ways in which you can do the different programs:

1.
Start a new project and a new source file for each program.

2.
Copy your old source file to a separate file.  Then delete the code from the old source file and use the now blank file to write the new code.

3.
Create a new source file by starting at step six of the instructions above.  Remove your old source file from the project by right clicking on the old source file name in the solution explorer and selecting Remove from the resulting menu.  (This does not delete the file; it simply means that the file is no longer part of the project.)
Saving your work and restarting
Make sure that you save your program file to the network drive or a floppy disk at the end of class.  The IDE will generate many files, but you can simply save the C++ source file.  When you have completed your work for the day, click on the start button to log off the computer.  Do not turn the computer off; simply log off the computer.
The easiest way to restart an existing project is to open the project file if it still exists.  You can do this if you have defined your project on the network drive or if you are using the same lab computer and no one else has removed your project.  There is no guarantee that your project will be available to you if it is only saved on a laboratory computer.  Someone else may be using the computer you used previously or all the student files on the hard drive may have been erased as part of the ongoing computer maintenance.  However, you will have the project file (1) if you are working on your home computer or (2) you have started the project on the network drive
 or (3) you use the same computer on which you started the project and you work has not been erased.  If Visual C++ is configured to have a start page, the available projects are listed on the start page.  Simply click on the one you want to open and you will be ready to continue your work.  If you do not see a start page, select Recent projects from the File menu, and click on the project you want to open from the submenu.
If you do not have an existing project, but you have an existing C++ source file, start by copying the source file to an appropriate location on the hard drive.  Follow steps 3 and 4 above to start a new project.  Then select Add Existing Item from the Project menu.  This will open a file location dialog box that you can use to locate the C++ source file that you copied to the hard disk.  This will add the file to the project, but it will not open it for editing.  Click on the file name in the Solution Explorer to open the file for editing
Syntax errors
The compiler will detect syntax errors and list these in a window at the bottom of the screen.  These error messages are in separate rows that have three main columns (1) a description of the error, (2) the file in which the error is located, and (3) the line number on which the error occurred.  You can adjust the width of these three columns by clicking the mouse on the border in the header row for the list of errors and dragging the border to obtain the desired column width.  It is usually helpful to make the description column as wide as possible.  Note that clicking on the description will place a small pointer to the left of the line with the error.  You have to correct all the errors before you can recompile your program.
Error messages are not always clear.  Sometimes the error will not be on the line indicated in the error message.  One common error is a missing semicolon at the end of the line.  This will be noted as an error on the following line.

Another example of a misleading error statement occurs when you omit a symbol from an output statement.  You will learn that the way to output text and the value stored in a variable, T, is the following statement:

      cout << "The answer is: " << T;

If you accidentally omitted the second << in this statement it would become: cout << "The answer is: " T; if you made this error you would have the following description of the error:
error C2146: syntax error : missing ';' before identifier 'T'

Here the complier has found a syntax error, but it has not correctly identified the error.  As you learn to write C++ code you will learn that such error messages do tell you that there is some error in the code, but you will have to apply your knowledge of C++ to identify the error correctly.
Sometimes the compiler will produce warning messages, but will still execute the program.  You should not ignore these warnings as they will usually indicate errors in your program.  Although these are not syntax errors (so the program will compile, link, and run) you will not get correct results.  For example, using a variable on the right-hand side of an expression, before it has been initialized is almost always an error.  The compiler will give you a warning for this.  You should make sure the variable is initialized before you run the program.
End of introduction
The sections above should allow you to start writing simple programs.  As your problems become more complex you will need to become familiar with the sections below on identifying and correcting errors in your program, and on coping with problems in using the Visual C++ .Net environment.

Copying the screen and preparing submission files

A submission file is a text file that contains all the information that you have to turn in for a programming assignment.  You will create this file at the start of your session and copy results from the source code listing and the output screen to this file.  When you are finished you will have a single file that you can print and turn in or submit by email.  You will be using this process for all laboratory assignments after exercise one.

Creating the submission file is a separate step that can be done between steps 8 and 9 of the general instructions above.

a.
start with the Project menu and select Add New Item from this menu.  This command will open a file selection dialog box that you have used to create a C++ file.  Here you will use it to create a blank text file.

b.
Choose the Visual C++ folder in the Catagories: menu in the upper left of the dialog and choose Text File (.txt) from the Templates: menu in the upper right.  (You may have to use the slider in this menu to find this selection.)

c.
Enter the file name in the next to last text box near the bottom (to the right of the word Name:).  (Pick a name like pex2.txt.)  Each task below will give you specific instructions about what you should place in this submission file.

There are several ways to place information into this submission file: (1) you can type onto this file, for example to write your name and the name of the assignment; (2) you can copy code from source files to this file using the copy and paste commands; (3) you can copy screen output (see instructions below) to this file.  Start by typing your name and the laboratory date at the top of this file.  You should also type a line on the submission file indicating the start of each new task.  You can have both the submission file and the C++ source open at the same time in the IDE.  You can select the file that you want to edit by clicking the various tabs above the editing region. (You can also select the file from the Window menu.)

You can copy the results from the display screen to a submission file by the following steps.

· Use the mouse to place the arrow in colored band at the top of the display screen.

· Right click the mouse button to display the menu for the display screen.

· Select Edit from the main menu and Mark from the edit submenu.  At this point, there will be a flashing block cursor in the upper-left-hand corner of the display screen.

· Use the mouse to select the text that you want to copy.  Hit the enter key after you have selected the text.

· Move to the file where you want to paste the copied text, place the cursor at the correct location in that file and execute the paste command by menu, icon or a control-V keystroke.

You can use this technique for any programming exercise, assignment or quiz.

Getting help
There are many ways to get help in Visual C++.  Although a “dynamic help” pane is displayed in the lower right corner of the screen, the approach that is often most useful is to select Search from the Help menu.  This will bring up a panel on the left side of the screen in which you can type some information about the item for which you are seeking help.  You can then limit the search to titles and click the Search button.  If this does not give you what you want, you can remove the limit on titles only, but this may give you references to topics that are not related to your question.  If you have an error code that you do not understand, you can simply list the error code in the search window.
Other errors
Your program may begin execution, but give incorrect results.  You have to review your program to see what is causing the errors.  There are a variety of errors that you can make while still keeping the correct syntax for C++.  The compiler will not catch these errors.  You should always test a new program with a set of data for which you know the answers.  If the program runs, but you get incorrect answers, you have to find and correct the error that produces the incorrect answers.
For simple programs an experienced programmer can often find the error by examining the code.  Some errors, such as incorrect equations or incorrect data, are simple blunders that you can make in any calculations.  Other errors that come about from an incorrect program are listed in the bullet list below.  You will not encounter some of these errors until later in the course.
· Using an int data type instead of a type double so that your results are based on integer division with truncation instead of division of real numbers.

· Writing an equation that appears correct, but does not have the correct operator precedence.

· Mislabeled output (e.g. the statement cout << “x = “ << y; will produce screen output such as x = 13.4, but 13.4 is the value of y, not the value of x.)

· Using an = instead of an == to test equality of two expressions.

· Having a looping index that is “off by one” because you used an incorrect starting or ending index or because you used < (or >) when you should have used <= (or >=).

· Using a semicolon at the end of an if, for or while statement that creates an empty control structure.  (Visual C++ flags this error with a warning message.)

· Incorrect use of braces that create an incorrect control structure.

· Mislabeled output (e.g. the statement cout << “x = “ << y; will produce screen output such as x = 13.4, but 13.4 is the value of y, not the value of x.)

Running the debugger
If you cannot find your errors by simply looking at your code, you can use the debug facility of the IDE.  With the debugger you can step through your code and examine intermediate results.  This identifies places where errors are occurring.  You can then focus your attention on a single statement (or group of statements), rather than an entire program, to see why there is an error.

Before running the debugger you can set breakpoints that halt program execution at a particular line.  When the program halts a yellow arrow will be pointing at the line that is just about to be executed.  You can observe the current values of variables in two windows below the program listing.  The window to the left has variables chosen by the debug system.  In the window to the right you can enter the names of variables (or expressions) and their value will be displayed.
You can step through program execution by clicking the step over icon (or pressing the F10 key) or the step into icon (or pressing the F11 key.)  The difference between these two keys is that the step into command will trace into functions; the step over command will bypass functions.  Variables that change by the most recently executed command will be highlighted in red.  Remember that the yellow arrow is pointing to a line that has not yet been executed.

Solutions to problems you encounter when using Visual C++ .Net
Students in this course encounter a variety of similar problems when using Visual C++.  Most of these are due to the design of the IDE as an advanced programming tool.  It is not sufficient to have only a C++ file that you are editing.  You must have the file associated with the project before you can compile link and run the program.  Furthermore, you must have only the file (or files) you want associated with the project.  Many problems students encounter with Visual C++ are due to the need to associate correctly files with projects.  Here are some tips about this issue.

· Never use the File -> New menu to open a source file that you want to compile.  Always use the Project -> Add New Item menu to make sure that your file is associated with the project.

· Never add more than one C++ source file to the project unless you have a large program that you have placed on more than one file.  If you are working on an assignment with two tasks and you want to create a separate file for each task, delete the old task file from the project.  You can do this by right-clicking the file in the Solution Explorer and selecting Remove from the resulting menu.
  

· In many assignments you will be asked to prepare a submission file which contains several program listings and copies of the output from the program.  Do not add the submission file to the project as a C++ file.  Doing so tells the compiler that you want to compile this file and link it to the project.  Instead you should add this file as a text file.
· Check the source file folder in the Solution Explorer to make sure that you are really compiling the file that you are editing.  It is possible for you to be editing a C++ file that is not being used as a source file by the project.  When this happens, the changes you make to the file, which is not part of the project, will not affect the output.
· If you find that you have been editing a file that is not part of the project, select Project -> Add Existing Item.  This will present you the usual file opening menu and you can then select the correct file to add to your project.
If you get an error message that says something about precompiled headers, you probably did an incorrect step in setting up your project.  To overcome this, 

· right-click the project name in the Solution Explorer and select Properties, which is at the bottom of the resulting menu.  This will give you a new dialog menu.

· Click on the C/C++ folder in the left panel to open the various categories; one of these will be precompiled headers.  Click on that name.

· In the pane on the right there are two columns.  If the second column says Not using precompiled headers, you are okay.  If not, use the pulldown menu on the right to select Not using precompiled headers.
If all else fails
If all else fails and you are unable to get the IDE to compile and execute your file, save your C++ file and start over with a new project.  Use the following steps to do this.

· Save your C++ file.

· Follow steps 2 and 3 on page 2 to start a new project.

· Select Add Existing Item from the Project menu.  This opens a file selection box that you can use to identify the C++ file that you saved.
· Click on the file name in the Solution Explorer to open the file for editing.  (Adding the file to the project will not open it for editing.)
Using the network drive
Creating and saving your projects on the University or College network drives will ensure that your files will not be removed during periodic cleanings of the hard drives.  In addition, you can access the work from any other computer in the University or College and you can work on any such computer that is equipped with the Visual C++ .Net 2003 IDE.  If you only store your files on the hard drive of the computer you are using, you will can only access them later by using the same computer.
To use the network drive, you have to select his drive from the Location text box in the New Project dialog.  To do this use, simply enter u:\ or z:\ before the project name and the file name in the text box (instead of entering c:\temp as you were instructed to do in step 3.e on page 2.

This will give you slower compilation and execution than using the hard drive of your local computer, but it will ensure that your files are always saved.

Do not forget step four








� See the section at the end of these notes on using the network drive.


� If the program has been used frequently, it will be listed in the original menu that you get after clicking on start.


� The left menu has a folder called Visual C++, with subfolders.  If one of the subfolders is selected, you may not have the choice of a C++ file in the Templates: menu on the right.  To correct this problem simply close the Visual C++ folder by clicking on the minus (-) sign to the left of the folder. 


� If you do not have a specific assignment, type the following lines into the program file.


#include <iostream>


using namespace std;


int main()


{


    cout << "Hello World!";


    return EXIT_SUCCESS;


}


� You perform steps 9 through 13 with one command by going to the Debug menu and selecting Start Without Debugging.  If you do this you will immediately get an error message telling you that certain project configuration(s) are out of date and asking you if you want to build them.  Click Yes to start the one step compile-link-execute process.  If the compiler or linker identifies any errors in your program you will get an error box informing you that there are errors and asking you if you want to continue.  Always lick No to view and correct your errors.  Clicking Yes will run the old version of the program


�Be careful if you use the save as command to save the old file.  The old file will appear in the IDE with the new file name.  Close this file and double click on the old file name listed as a source file in the solution explorer.  You can then delete this code and use this blank file for your new code.


� See the section at the end of the notes for instructions on using the network drive.


� You can also remove the file by selecting the file name in the solution explorer and pressing the delete key.  This seems frightening at first because you think that you are deleting the file.  You are not.  You are simply removing it from the project.
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