Excel Data Query and Management

Using Excel for Data Query and Management

Save yourself time, energy, keystrokes and headaches. Learn some of Excel’s more advanced functions to help you manage and query large or multiple data worksheets.

Some Great things About Excel:
1. Excel is an extremely powerful application.
2. It gives a lot of visual clues to help you as you work with your data.
3. This guide will give you insight and steps to follow to utilize some of the advanced capabilities and tools in Excel.
4. Many of the operations use buttons on the toolbars.
5. Understanding and utilizing the features in this documentation will help save time and energy.
6. Most importantly, have fun and practice.

Table of Contents
1. Freezing the View Pane
2. Sorting Data
3. Filtering & Querying Data
4. Creating & Removing Subtotals
5. Data Validation
6. Auditing Worksheets

Freezing Panes

Keeping the titles in view by freezing panes

Most worksheets are set up with row or column headings. It is easy to lose track of just where you are when you scroll to a different location in the worksheet. Excel provides a handy solution to this problem, Freezing Panes. This keeps the headings visible while you are scrolling through the worksheet.

Freezing panes prevents the row or column headings from scrolling out of view as you navigate the worksheet. Frozen panes are indicated by a line below a row and a line to the right of a column. See Figure 1 below.
To freeze panes:
   1. Move the cell pointer to the cell below the row that you want to remain visible as you scroll, and to the right of the column that you want to remain visible as you scroll.
   2. Select the **Window menu**
   3. Select **Freeze Panes**

**Sorting Data**

**Sorting Data—Working with data in a list**

In some cases, the order of the rows in your list doesn’t matter. But in other cases, you want the rows to appear in a specific order. For example, in a personnel list, you may want the rows to appear in alphabetical order by last name. Or, if you have a list of expenditures, you may want to sort the list by date in ascending order.

Rearranging the order of the rows in a list is called *sorting*. Excel is quite flexible when it comes to sorting lists, and you can often accomplish this task with the click of a mouse button.

Excel automatically treats any worksheet list as a database, allowing you to perform any of the commands on the Data menu. The rows serve as **records**, with columns serve as **fields**. When you have a data list in Excel, you can sort the list and filter the list to show only specific data.

There are a few simple rules when creating your data list that you need to follow.

1. Include only one list per worksheet.
2. Include one blank column and one blank row between the list and any other data in the worksheet.
3. Include column labels (titles) at the top of the list and format the
4. Do not include any blank rows or columns in the data list.

How Sorting Works

When you sort a list, Microsoft Excel rearranges rows according to the contents of a column you choose - the Sort By Column.

Sorting the simple way

The sort order is the way you want the data arranged. You can sort alphabetically or by value, and in ascending or descending order. For example, when you use an ascending sort order, numbers are sorted from 1 to 9, text is sorted from A to Z, and dates are sorted from earliest to latest.

To perform a simple sort of a list using the Sort Descending or Sort Ascending icons on the Standard Toolbar (Figure 2 below) use the following steps:

1. Select a cell within the column that you want to sort.
2. Do one of the following:
   - Click on the Sort Ascending button on your standard toolbar to sort the list in ascending order.
   - Click on the Sort Descending button on your standard toolbar to sort the list in descending order.

Excel sorts the list according to your specifications. To undo the last sort, click the Undo button on the Standard toolbar. You can also undo the sort by clicking on the Undo Sort from the Edit menu.
Sort Orders:

**Ascending Order**
- Numbers from the smallest negative number to the largest positive number; dates and times, from earliest to latest.
- Text values, sorting numbers entered as text first, then regular text.
- Logical values, FALSE then TRUE.
- Error values, such as #VALUE! Or #NAME?, in the order in which they are found.
- Blanks

**Descending Order** - is simply the opposite of ascending order.

**Restoring the Original Order of the List**
If you want to perform a series of sorts and return the list to its original order:
1. Prior to beginning a sort, insert a new column adjacent to the list.
2. Type “1: in the first cell beside the first row of information and “2’ in the second cell beside the first row of information.
3. Use AutoFill to complete the consecutive numbering for the entire length of the list.
4. When you have completed the series of sorts, and want to return the list to its original order, sort the numbered column in ascending order.

**Performing more Complex Sorting**

Sometimes, you may want to sort by two or more columns. Excel allows you to specify the priority of up to three columns by which you can sort the list. Figure 3 shows an example of an unsorted list.

**Figure 3**

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Journal</td>
<td>Date</td>
<td>DeptID</td>
<td>Fund</td>
<td>Program</td>
<td>Class</td>
<td>ProjGrp</td>
<td>Dept</td>
<td>Amount</td>
</tr>
<tr>
<td>2</td>
<td>0000000754</td>
<td>2001/07/31</td>
<td>10162</td>
<td>T496U</td>
<td>0406</td>
<td>DPTCLOSEOUT</td>
<td>6620100</td>
<td>Supplies and Services</td>
<td>1,957.76</td>
</tr>
<tr>
<td>3</td>
<td>0000000774</td>
<td>2001/07/31</td>
<td>10163</td>
<td>L341C</td>
<td>0101</td>
<td>DISCRETIONARY</td>
<td>6620150</td>
<td>I/T Communications under $5k</td>
<td>1,983.08</td>
</tr>
<tr>
<td>4</td>
<td>0000000737</td>
<td>2001/08/31</td>
<td>10163</td>
<td>T498U</td>
<td>0101</td>
<td>MOU</td>
<td>6620100</td>
<td>Supplies and Services</td>
<td>35.00</td>
</tr>
<tr>
<td>5</td>
<td>0000000003</td>
<td>2001/07/01</td>
<td>10155</td>
<td>L341C</td>
<td>0101</td>
<td>DISCRETIONARY</td>
<td>6620100</td>
<td>Supplies and Services</td>
<td>241.92</td>
</tr>
</tbody>
</table>

If you sort this list by date, Excel places the rows for each date together. But, you may also want to show the Department ID in ascending order within each date. In this case, you need to sort by at least two columns (Date and
Department ID). Multiple column sorts require the use of the **Sort** command form the **Data** pull-down menu.

1. Select a cell in the column in which you want to sort.
2. To sort data, use the **Data** pull-down menu and select the **Sort** command. Excel will display the dialog box shown in Figure 4.
3. Select the column heading in the “**Sort by**” selection by selecting the drop down box in this section.

![Sort dialog box](image)

Figure 4
If you have used the **Sort** command before, Excel displays the last column you selected. However, Excel recognizes the column headings, defaults to the left-most column heading, and places the column heading selections in the drop-down boxes.

**Figure 5**

4. Click on **Ascending** or **Descending**, depending on how you want Excel to sort the column.

5. Specify additional sorting criteria by selecting the column headings you want in the **Then by** boxes.

6. In the **My list has** box, click on **No header row** if the first row of your list does not contain row headings.

7. Click on **OK**

Excel sorts the data in your list according to your specifications.

- If the sorting did not occur as you expected, select Edit → Undo (or press Ctrl + Z) to undo the sorting.
- What if you need to sort your list by more than three fields? It can be done, but it takes an additional step. For example, assume that you want to sort your list by five fields: Field 1, Field 2, Field 3, Field 4, and Field 5. Start by sorting by Field 3, Field 4, and Field 5. Then resort
the list by Field 1 and Field 2. In other words, sort the three “least important” fields first; they remain in sequence when you do the second sort.

**Changing the Sort Orientation**

Excel allows you to change the sort orientation so that you can sort your information by rows rather than columns.

To change the sort orientation, use the following steps:

1. Select a cell in the row in which you want to sort.
2. Click on the **Data** menu and click on **Sort**.
   Excel displays the **Sort** dialog box.
   (See Figure 5)

3. Click on **Options**.
   Excel displays the **Sort Options** dialog box (Figure 6 above)
   a. The **First key sort order** field allows you to select a custom sort order, such as by days or months.
   b. The **Sort left to right** selection sorts columns with a single row as the basis of the sort. Excel automatically uses the column
headings to sort the list.

c. The “Sort top to bottom” selection sorts rows with a single column as the basis of the sort.

d. The “Case sensitive” selection sorts on capitalization.

4. Make your selections from the options provided.
5. Click on OK. Excel returns you to the Sort dialog box.
6. Click on OK. Excel sorts the list according to your specifications.

Sorting by a Column that contains numbers or text and numbers

- If the Sort By column contains numbers, make sure the numbers are all in a numeric format, or are all formatted as text.
- If the column you want to sort by contains both numbers and numbers that include text characters (such as 100, 100a,), format them all as text if you want to sort them together. If you do not, Excel will sort the numbers first, then the numbers that include text (100, 200, 100a, 200a). To format a number as text, precede the number with an apostrophe (’).

How Excel Identifies Column Labels

Microsoft Excel identifies labels by comparing the formatting in the top rows of your list. If there is a difference between the rows - such as data type, capitalization, font alignment, or pattern - Excel identifies the first row as column labels and excludes it from the sort. Excel can identify up to two rows or column labels.

Sorting a List That Does Not Have Column Labels

If there are no differences in data type, capitalization, font, alignment, or pattern between the first rows and the rows that follow, Excel will not identify column labels. Excel automatically selects the No Header Row option button under “My List Has” in the Sort dialog box. If for some reason, Excel identifies your first row as column labels but you want to include the row in the sort, manually select the No Header Row option button. You can then select a column to sort by using the generic column headings (Column A, Column B, and so on).

Sorting Columns Left to Right in a List

With the Sort command, you can sort columns instead of rows. Choose the Options button in the Sort dialog box. In the Sort Options dialog box, select
the Sort Left to Right option button, and then choose the OK button. **Then select the rows you want to sort by** (Row1, Row2, and so on) in the Sort By and Then By boxes.

### Sorting Selected Data

To sort only a subset of rows, or to sort the data in a single column of a list, first select the rows or columns you want to sort before you choose the Sort command.

If you select data in a single column or row, Excel displays a message asking you to confirm that you want to sort only the selected cells. If you select the Continue with the Current Selection option button and complete the sort, Excel sorts only the selected data, leaving the surrounding data in place.

**Note of Caution** Sorting selected data does not move data in adjacent columns or rows.

### Filtering & Querying Data

#### How Filtering Works

Filtering is a quick and easy way to find and work with a subset of data in a list. When you filter a list, Excel displays only those rows that meet a set of search conditions called criteria.

- Filtering does not rearrange a list
- Filtering temporarily hides rows you do not want displayed.

There are **two ways to filter** a list in Excel:

- Use **AutoFilter** to filter your list quickly by matching cell contents or using simple comparison criteria, such as “display rows where Expense is greater than 2000”
- Use **Advanced Filter** to filter data based on complex or computed criteria. You can also use Advanced Filter to automatically copy data that meets specified criteria to another location.

When you are in Filter mode, you can edit, format, chart, and print your list subset without rearranging or moving it.
Filtering a List Using AutoFilter

1. From your pull down menu select **Data > Filter**, then **AutoFilter**. (See Figure 7)

   ![Figure 7](image)

   - Once you are in auto filter mode **drop-down arrows are displayed** directly on the column labels on your list. (see Figure 8)

   ![Figure 8](image)

2. **Click the AutoFilter drop-down arrow in a column heading to display a list of all the unique items in the column.** (see Figure 8)

   By selecting an item from a list for a specific column, you can instantly hide all rows except those rows that contain the selected value. (See Figure 9)

   ![Figure 9](image)
The item you select in a column drop-down list is called the filter criterion. You can filter your list further by choosing another criterion from another column.

- If the list of items is long, you can quickly move to an item by selecting the arrow, then typing the first letter of the item.

**Visual cues that you are in Filter Mode**

Once a filter criterion has been placed in a column, the arrow in the column header will appear blue on your worksheet. (See Figure 10)

![Figure 10](image)

- **Row headings appear blue** on the worksheets.
- The status bar displays the number of rows that meet the criteria, or the text “Filter Mode”.

**Note** - Excel allows you to filter one list at a time on a worksheet.

**Removing a Filter**

- To remove filter criteria for a single column, select “All” from the column’s drop-down list.

- To show all hidden rows in the list, select Data from your pull down menu, then Filter, then Show All.

- To display all hidden rows and remove the AutoFilter arrows, select Data from the pull down menu, then Filter, then deselect the AutoFilter command.
Filtering a Subtotaled List

- Excel does not recalculate automatic subtotals when you filter
- Sort and Filter your list before you insert automatic subtotals.

Using Custom Criteria with AutoFilter

Each individual column can specify custom criteria.

This is useful when you want to:

- **Display rows that contain either of two items** in a text field, such as rows that contain the account number for staff salaries and rows that contain the account number for management and supervisory salaries all under the Account column.
- **Display rows that contain values that fall within a range of values** such as rows that contain expenditures greater than 5,000 and less than 10,000.

To perform a custom criterion:

1. From the Filter Arrow, choose **custom option** from the drop-down list for the column.
2. Specify custom criteria, by selecting the comparison operator you want to use. Such as “greater than” or “equal to”. If you specify two custom criteria, choose how you want excel to apply the criteria.

Excel allows you to filter with a Single Criterion or a Multiple Criterion.

Creating and Removing Subtotals

Creating Subtotals

As with many of Excel’s analysis tools, before you use the Subtotals feature you must make sure your data meets specific guidelines.

- **The principle rule** is that your data’s first row must consist of labels that describe the data included in each column.
- Next, be sure to Sort & Filter your list as appropriate, using the Sort & Filter functions. The Subtotals feature breaks down your data based on recognizable field groupings.
For example, if you want to display the subtotals for each Dept ID in the Expense column, Sort the Dept ID column before creating subtotals.

- Now your data is ready to create subtotal values. The Subtotal feature allows you to create subtotals of values in lists automatically without the need to create a formula. You can quickly and easily total columns or rows by category. Excel will automatically add a grand total at the bottom of the list. It will also put a sort level to the right of your data chart that you can click on and view at each sort level.

Once your document is ready to subtotal, follow these simple steps:

1. From the Data pull-down menu select Subtotal.

   The subtotal dialog box will appear (Figure 11)

   ![Figure 11](Figure11.png)

2. Click on the arrow in the “At each change in” box to display the column headings in your list. Select the column heading you want.

3. Click on the arrow in the Use function box to select the function you want.

   Excel defaults to the Sum function for numeric values and the Count function for text.
4. Next, in the **Add subtotal to**: field, select or de-select the appropriate column box in which you want the subtotal total to appear.

5. Last, click on the **OK** box.

➢ To remove the subtotals from the worksheet, go back to the **Data** pull-down menu and select **Subtotal**. The subtotal dialog box will appear. In the bottom left corner of the box is a button titled “**Remove all**”, single click on this button.

**Data Validation**

Part of creating efficient and easy-to-use worksheets is to do what you can to ensure that the data entered into your worksheets is as accurate as possible. Using a validation rule can make sure the data entered into a cell meets certain standards.

**Defining a Valid Set of Values for a Range of Cells**

To create a validation rule:

1. From the **Data menu**, select **Validation**.
2. Excel will display the Data Validation dialog box (see figure below)

![Data Validation Dialog Box](image)

The **Data Validation dialog box** is used to define the type of data that Excel should allow in the cell and then, depending on the data type you choose, to set the conditions data must meet to be accepted in the cell. For example: a column is set up to enter a person’s phone number and someone tries to enter the person’s name instead. By setting up accurate validation rules, the cell will only accept numeric values.

The **Settings tab** is used to specify the type of data that the cell should contain. The dialog box changes, depending on your choice in the Allow box.

3. Select the drop down menu arrow in the Allow field to view and change the choices. (See figure below). Depending on your choice, other validation criteria fields may appear and will need to be completed.
To apply a validation rule to a group of cells you must select the cells first, and then set the validation rule.

4. Select the Input Message Tab

The **Input Message** tab is used to specify a message that will appear when the cell is selected. This is an optional item. The message appears in a small pop-up box.
Excel lets you create messages that tell the user what values are expected before data is entered. If the conditions are not met, it will reiterate the conditions in a custom error message when the Error Alert Tab criteria fields are completed. (See figure example below)

**Figure - Sample of Input Message for data validation.**

5. Input the Title you want to give the message in the Title field. See sample above. The figure on next page shows the results of the validation message.
6. Input the Input message in the appropriate field. See sample above.

7. Select the Error Alert Tab.

The **Error Alert** tab is used to specify the message that will appear in a dialog box if invalid data is entered. This is optional.

8. There are 4 different options to complete. Each field is optional.
   - The Show error alert after invalid data is entered check box
- Style field - allows 3 choices of warnings style
- Title field- Input title or warning
- Error Message field - Input text message you want to appear.

Below are samples of Data Validation settings and error alert settings.

- The sample below shows a validation criteria set up for a column on a spreadsheet to accept only dates between July 1, 2005 and June 30, 2006.

**Figure - Sample of Data Validation Criteria set up on the Settings tab.**

- The sample below shows additional validation criteria set up for the column on the spreadsheet that is to only accept dates between July 1, 2005 and June 30, 2006.
- This Error Alert setting will produce a warning pop-up box if the criteria on the Settings Tab are not met. (see Figure below for pop-up box sample)
The figure below is a sample of the Error Alert pop-up box warning that appears when the criteria on the Settings Tab is not met.

**Figure - Sample of Additional Data Validation Criteria set up on the Error Alert tab to produce a warning pop-up box when the criteria on the Settings Tab is not met.**

- The figure below is a sample of the Error Alert pop-up box warning that appears when the criteria on the Settings Tab is not met.

**Figure - Error Alert pop-up box warning.**

Sample pop-up box warning.
Auditing Worksheets

Displaying the Auditing Toolbar

The **Auditing toolbar** is Excel's primary source for tools that allow you to audit your worksheet to find and correct the errors that will inevitably occur.

To display the **Auditing** toolbar:

1. Click on the **Tools** menu.
2. Point to **Formula Auditing**, and
3. Click on **Show Formula Auditing Toolbar**.

![Figure 12](image)

The auditing toolbar will appear. See figure 13.

![Figure 13](image)
Below is an explanation of each icon on the auditing

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Error Checking</td>
<td>Checks for errors in the current worksheet and displays a dialog box advising if any errors were found.</td>
</tr>
<tr>
<td>Trace Precedents</td>
<td>Clicking on this button allows you to find the cells that supply data to a formula. If data is supplied from more than one level of cells, each click on this button will reveal another level. Excel displays a blue arrow from all cells supplying data to the selected cell.</td>
</tr>
<tr>
<td>Remove Precedent Arrows</td>
<td>Will allow you to remove precedent arrows for each level displayed. If data is supplied from more than one level of cells, click on this button again to remove precedent arrows for each level.</td>
</tr>
<tr>
<td>Trace Dependents</td>
<td>Will allow you to find all cells that depend on the selected cell. For example, if you select a cell containing data, you can find all the formula cells that refer to the cell data.</td>
</tr>
<tr>
<td>Remove Dependents Arrows</td>
<td>Will allow you to remove dependent arrows for each level displayed. If the selected cell has more than one dependent, each click on the button will remove dependent arrows for each level.</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Remove All Arrows</td>
<td>Will allow you to remove all tracer arrows in the worksheet.</td>
</tr>
<tr>
<td>Trace Error</td>
<td>Will allow you to find the source of an error. Draws a red arrow from the cell that contains an error to the cells that may have caused the error. This button works only when an error message appears in the selected cell.</td>
</tr>
<tr>
<td>Note Comment</td>
<td>Will allow you to add a comment to a cell. For example, you may want to review the worksheet at a later date with specific figures in mind. Excel displays a small red arrowhead in the upper-right corner of the cell.</td>
</tr>
<tr>
<td>Circle Invalid Data</td>
<td>Draws a red circle around all the cells that contain invalid data. This applies only to cells that have validation criteria specified with the Data &gt; Validation command.</td>
</tr>
<tr>
<td>Clear Validation Circles</td>
<td>Removes the circles that are drawn around cells that contain invalid data.</td>
</tr>
<tr>
<td>Show Watch Window</td>
<td>Displays the Watch Window so that you can keep track of the values of specified cells. The Watch Window is simply a small box that allows you to see the values of cells even if those cells do not currently appear onscreen.</td>
</tr>
<tr>
<td>Evaluate Formula</td>
<td>Displays the Evaluate Formula dialog box so that you can view the formula and formula results in the selected cell. If the cell contains a complex formula, you can evaluate individual sections of the formula independently.</td>
</tr>
</tbody>
</table>