Excel 2007

Working with Multiple Workbooks & Sheets

IT Training & Development
(818) 677-1700
training@csun.edu
http://www.csun.edu/it/training/
Table of Contents

Introduction ............................................................................................................................ 1
Making Changes To The Sheet Tab ....................................................................................... 1
  Deleting a Worksheet ........................................................................................................ 1
Hiding and Un-hiding a Worksheet ......................................................................................... 1
  To Hide a Worksheet ....................................................................................................... 1
  To Display a Hidden Worksheet ...................................................................................... 2
Moving and Copying A Worksheet ......................................................................................... 2
  Moving a Worksheet ....................................................................................................... 2
  Moving Several Sheets at One Time ................................................................................ 3
  Copying a Worksheet ...................................................................................................... 3
  For Mac Users ................................................................................................................. 4
Moving and Copying a Sheet Between Workbooks ................................................................ 4
  Viewing Multiple Workbooks ......................................................................................... 4
  Moving Sheets between Workbooks ............................................................................... 4
  Copying Sheets between Workbooks .............................................................................. 4
Creating and Working With Graphic Objects ....................................................................... 5
  What Tools Do I Use? ...................................................................................................... 5
  Using Shapes to Create Your Graphic Object .................................................................. 6
    Deleting Graphic Objects .............................................................................................. 7
  Sizing, Moving, and Copying Graphic Objects ................................................................ 7
    Resizing an Object ....................................................................................................... 7
    Moving an Object ....................................................................................................... 8
    Copying an Object ...................................................................................................... 8
  Drawing Tools Functions ............................................................................................... 8
Creating Basic Charts .......................................................................................................... 9
  Creating Your First Chart – The Easy Way .................................................................... 9
Protecting Your Data .......................................................................................................... 12
  Unlocking Individual Cells on a Worksheet ................................................................. 12
  To Assign a Password to a Workbook .......................................................................... 14
  Protecting Workbook Structure and Windows ............................................................ 15
Removing a Password ......................................................................................................17
Linking Information........................................................................................................17
  Linking Information between Worksheets in a Single Workbook...............................18
  Linking Information between Open Workbooks .........................................................19
  Moving Links between Workbooks ............................................................................20
TRAINING AND SUPPORT ...........................................................................................21
  IT Training ...................................................................................................................21
INTRODUCTION

Excel is a very powerful program. It is nearly impossible to know everything about Excel. However, this guide will provide you with information and techniques to effectively utilize multiple workbooks and worksheets simultaneously. Understanding these techniques and functions will save you time, energy, keystrokes and headaches.

MAKING CHANGES TO THE SHEET TAB

Deleting a Worksheet

Excel allows you to delete unwanted worksheets in a workbook. One thing to remember when deleting a worksheet—if there is data on the worksheet, that data is also deleted. To delete excess sheets in a workbook do the following:

1. Select the worksheet to be deleted. To select multiple worksheets, hold down the Ctrl key while clicking on the worksheet tabs.

2. Right-click, and select Delete from the short-cut menu.

Excel will delete the selected worksheet(s).

HIDING AND UN-HIDING A WORKSHEET

Excel gives you the ability to hide worksheets that are in a workbook. You might ask, why would I need to hide a worksheet? Hiding a worksheet is useful if you do not want others to see it, or if you just want to get it out of the way. When a sheet is hidden, its sheet tab is also hidden.

Hiding a worksheet may also prevent casual users from viewing or changing important information in a workbook.

To Hide a Worksheet

1. Select the worksheet you want to hide.

2. From the Home tab, in the Cells group, select Format (see Figure 1).
3. Under **Visibility**, select **Hide & Unhide**, and then select **Hide Sheet**.

The active worksheet (or selected worksheets) will be hidden from view. Every workbook must have at least one visible sheet, so Excel won’t allow you to hide all the sheets in a workbook.

**To Display a Hidden Worksheet**

1. From the **Home** tab, in the **Cells** group, select **Format**.

2. Under **Visibility**, select **Hide & Unhide**, and then select **Unhide Sheet**.

3. In the **Unhide Sheet** box, double-click the name of the hidden sheet that you want to display. You can only unhide one worksheet at a time.

**MOVING AND COPYING A WORKSHEET**

**Moving a Worksheet**

Worksheets can be moved within a workbook and between workbooks. In a workbook, you can put them in the order you want them.

1. Select the sheet tab that you want to move.
2. Hold the left mouse button down and drag the sheet tab to its new location. When you drag a sheet, a small worksheet icon appears at the tip of your pointer arrow; another tiny black arrow appears at the beginning of the sheet tab (see Figure 1). This tiny black arrow indicates where the sheet will be inserted in the tab order.

Figure 1 – Moving a Worksheet (Black Arrow)
3. Release your mouse button and the sheet will be inserted into the placement indicated by the small black arrow.

**Moving Several Sheets at One Time**

Using the same technique as in the previous section, you can move several sheets at one time.

1. Select the first sheet you want to move.

2. While holding down the **Shift** key, select the next sheet. This will indicate a range of sheets to move i.e. sheet1:sheet 2 (see Figure 2).

![Figure 2 – Selecting Multiple Sheets](image)

3. Now, drag the sheet or range of sheets to their new locations.

**Copying a Worksheet**

To copy a worksheet:

1. Select the sheet or sheets to copy.

2. Next, hold down the **Ctrl** key and drag the small black arrow indicator to the far right of the current sheets (see Figure 3).

![Figure 3 – Copying a Sheet](image)

**Note**: When you copy an entire sheet, the identical sheet appears in a new location. A number will appear in parenthesis on the copy to distinguish it from the original sheet (see Figure 4).

![Figure 4 – Sheet Copy](image)
For Mac Users

1. Select the sheet or sheets you want to copy.
2. From the Edit menu choose Move or Copy.
3. In the Move or Copy dialog box, check the Create a copy box.
4. Select the OK button.

MOVING AND COPYING A SHEET BETWEEN WORKBOOKS

Excel has the ability to move or copy sheets from a current workbook to another open workbook by simply dragging the sheet.

Viewing Multiple Workbooks

To view more than one workbook at a time:

1. First, open all of the workbooks.
2. Next, from the Window pull-down menu, select Arrange.
3. From the sub-menu, select Tiled.

Moving Sheets between Workbooks

1. Open both workbooks.
2. Select the sheet tab you wish to move from workbook 1 to workbook 2.
3. Hold the left mouse button down, and then drag the sheet from workbook 1 to where you want it to go.

Copying Sheets between Workbooks

1. Open both workbooks.
2. Select the sheet tab you wish to copy in workbook 1 to workbook 2.
3. Hold the left mouse button and the Ctrl key down.

The mouse pointer will be a fat white arrow with a small piece of paper behind it, on the paper should be a plus (+) sign (see Figure 1).

![Figure 1 – Copying a Worksheet](image1.png)

4. Drag the sheet from workbook 1 to where you want it to be in workbook 2. A copy of the entire sheet is placed in workbook 2.

## CREATING AND WORKING WITH GRAPHIC OBJECTS

With Microsoft Excel you can create a variety of graphic objects - boxes, lines, circles, ovals, arcs, freeform polygons, text boxes, buttons, and a wide assortment of complex predefined objects called "AutoShapes". You can specify font, pattern, color, and line formats, and you can position objects in relation to the worksheet or to other objects. You can also take pictures of your worksheets and use them in other Excel documents or in documents created in other applications.

This section is intended to acquaint you with MS Excel’s Drawing and Graphic Object features.

### What Tools Do I Use?

The **Illustrations** grouping is all you need.

1. On the **Ribbon**, select **Insert > Shapes**.

![Figure 1 – Shapes](image2.png)
Using Shapes to Create Your Graphic Object

2. The **Shape** list displays (see Figure 2). Select the object that you want to work with.

![Figure 2 – Shape List Options](image)

3. After selecting the object, move your mouse to the area on your worksheet that you want the object to appear.

4. Click and drag to the appropriate size.

When you release your mouse button and move the mouse pointer away from the object you are drawing, Excel assumes you are finished and the pointer resumes its usual plus-sign shape, indicating that you are no longer in drawing mode. Excel automatically leaves drawing mode each time you finish drawing an object.

You may can cancel drawing mode by clicking anywhere in the worksheet or chart without dragging.
Deleting Graphic Objects

To delete a graphic object:

1. Select the object.
2. Press the **Delete** key.
3. Repeat as needed.

Sizing, Moving, and Copying Graphic Objects

You can change the size, position and formatting of graphic objects you have created.

Resizing an Object

1. Select the object and position the mouse pointer over the selection handle.

**Note:** The selection handles appear as little squares around the object. Your mouse pointer will change to a two-sided arrow pointer.

2. Drag the shape to resize it.
3. Release the mouse button.

In the figure below, the top star is before resizing the object. The bottom star has been resized.

Figure 4 – Original Object & Resized Object
### Moving an Object

1. Position the mouse pointer over the object so that it changes to a 4-way arrow (see Figure 5).
2. Drag to the new position.
3. Release the mouse button.

![Figure 5 – 4-Way Arrow](image)

### Copying an Object

To copy an object:

1. Hold down the `Ctrl` key as you drag the object to a different location. This will create a duplicate object if you are using a Windows-based machine.

### Drawing Tools Functions

Once the object has been added, you can edit the graphic object by using the **Drawing Tools** that are provided within the application.

1. Double-click the object that you want to edit.
2. **Drawing Tools** displays along the **Ribbon** (see Figure 6).

![Figure 6 – Drawing Tools](image)
One important item to mention is that these options will change depending on the shape you are working with. For example, if you are working with a line object, the **Shape Styles** group will reflect this and options that do not pertain to line objects will be grayed out and unavailable for use.

- **Insert Shapes Group** – The **Insert Shapes** group includes the shapes or objects that are available to you. This group also includes an option to add text boxes or to edit an existing shape.

- **Shape Styles Group** – The **Shape Styles** group includes fill options such as colored fills and shape fills. This group also includes shape outline and shape effect options.

- **WordArt Styles Group** – The **WordArt Styles** group includes various WordArt styles, text fills, text outlines and text effects. Basically, everything pertaining to text.

- **Arrange Group** – The **Arrange** group includes options that pertain to the placement of the object such as bring to front, send to back and rotate.

- **Size Group** – The **Size** group includes options to adjust the height and width of an object.

## CREATING BASIC CHARTS

Charts are a graphical means of making data more understandable. Charts are particularly useful for understanding a lengthy series of numbers and their interrelationships. A chart can help you to spot trends and patterns that would be nearly impossible to identify when examining a range of numbers. You create charts from data in a worksheet.

### Creating Your First Chart – The Easy Way

If you’re new to chart making, you may wonder how much work is involved in creating a chart in Excel. As you’ll see in this section, the whole process is quite simple.

1. Enter the data to be charted into a worksheet. Typically, you want to include several rows and columns of data, as well as labels to indicate what the data represents.

2. Select a cell (any cell) in the range of data that you entered in Step 1. Excel will automatically determine the size of the range.

3. From the **Ribbon**, select **Insert** (see Figure 1).
4. In the **Charts** group, select the chart type you’d like to work with (Column, Line, Pie, etc). In this example, we will use **Column**.

5. A list of additional Column options display (see Figure 2).

6. Select the chart type you’d like to work with.
7. The chart displays next to your data cells (see Figure 3).

Figure 3 – Completed Chart

8. Once the chart has been added, the Chart Tools contextual toolbar displays at the top of the window (see Figure 4).

Figure 4 – Chart Tools

9. Use the Chart Tools options to edit the chart. Changes such as type, color or design can be done from this toolbar.

Note: Charts are objects. Objects do not have a cell location. They float on top of a worksheet, on the worksheet’s draw layer. As with all objects, you can move a chart, resize it, change its proportions, adjust its borders, and perform other operations.

A chart is not stagnant. You can always change its type, add custom formatting, add new data series to it, or change an existing data series so that it uses data in a different range.

To make any changes to the actual chart, you must select it first.
PROTECTING YOUR DATA

Excel provides many ways to protect your data. One way is password when you save your file. However, Excel also offers several commands that let you protect workbooks, workbook structures, worksheets and individual cells from access or modification by others. This type of protection is handy when you are sharing files.

**Password protection in Excel is serious business.** Once you assign a password, there is no way to unprotect the sheet or workbook without it. Don’t forget your passwords! And remember, capitalization matters! Passwords are case sensitive.

By default, Excel locks (protects) cells, graphic objects, charts, etc. but the protection is not complete until you activate the protection. This section will show you step by step how to protect your data in a variety of ways.

Passwords can be assigned to workbooks, worksheets, or even a range of cells within a worksheet. Users can gain access to the workbook/worksheet only by providing the password you assign. If you try to change the content of a locked cell, Excel displays an error message (see Figure 1). Locked cells cannot be changed.

Figure 1 – Locked Cells Error Message

Unlocking Individual Cells on a Worksheet

There are occasions when you want to lock specific cells in your worksheet. For example, when you are sharing a workbook and you want others to enter quarterly information but not alter the formulas that will be in the total columns.

This process must be done PRIOR to protecting your workbook or worksheet.

Excel does not have a command process to lock specific cells. This must be accomplished in reverse. We want to unlock specific cells. To do this, use the following steps:

1. Before you protect a worksheet, select (highlight) the cells or range of cells you want to keep unlocked.
2. From the Ribbon, in the Cells group, select Format (see Figure 2).
3. Select **Format Cells** (see Figure 3).

4. Select the **Protection** tab (see Figure 4).
5. De-select the **Locked** checkbox by clicking on it.

6. Select the **OK** button.

Excel does not provide any on-screen indication of the protection status of individual cells. To distinguish unlocked cells from the protected cells in the worksheet, change their format; for example, you can change cell color or add borders.

### To Assign a Password to a Workbook

Assigning a password to a workbook allows you to protect the workbook and its contents upon opening. When a workbook has this type of protection, only an individual who knows the password assigned to the document will be able to open it.

Use the following steps to assign a password to a workbook:

1. Open the workbook.

2. From the **Microsoft Office** button, select **Save As**.

3. From the **Tools** button, select **General Options** (see Figure 5).

**Figure 5 – Tools > General Options**
4. The **General Options** window displays. Enter the password that you’d like to assign to the file into the **Password to open** field (see Figure 6).

![General Options Window](image)

**Figure 6 – General Options Window**

Note: The password you use is limited to 15 characters. It can be a mixture of alpha and numeric characters but the first character should be an alpha character. The password fields are case sensitive.

5. In the **Password to modify** field, enter the password that you would like users to use.

6. Select the **OK** button.

7. Excel will return to the **Save As** dialog box. Select the **Save** button.

8. Excel asks if you want to replace the existing file. Select **Yes**.

9. The file has been saved and the password has been assigned.

**Protecting Workbook Structure and Windows**

Once you have opened the workbook, you can also protect the workbook structure and windows from being modified.

- Protecting the **Structure** prevents modification of the worksheet arrangement in a workbook.

- Protecting the **Windows** prevents moving or resizing of the workbook window.

To enable these protections:

1. With the worksheet open, select **Protect Workbook** (see Figure 7).
2. The **Restrict Editing** menu displays. Select **Protect Structure and Windows**.

3. The **Protect Structure and Windows** dialog box displays (see Figure 9). In the **Protect workbook for** section, select the appropriate option.

4. In the **Password** field, enter a password. The **Password** field is case sensitive.

5. Select the **OK** button.

Your workbook structure and/or windows are now secure.
**Removing a Password**

You can remove both the access and write reservation password from a workbook once you no longer want to protect it.

To remove a password from a workbook, use the following steps:

1. Open or activate the workbook.
2. From the **Microsoft Office** button, select **Save As**.
3. In the **Save As** dialog box, select **Tools** (from the lower, left corner), then select **General Options**.
4. Highlight the password characters that appear in the **Password to open** and/or **Password to modify** fields.
5. Press the **Delete** key on your keyboard.
6. Select the **OK** button.
7. Select **Save**.
8. Excel will ask if you want to replace the existing file. Select **Yes**. Excel will save the file and remove the password protection.

**LINKING INFORMATION**

Do you find yourself entering the same information on multiple worksheets? Then having to update this information on each sheet? Frequently, you may have the same information in multiple sheets. Linking can save you time and effort by allowing you to:

- Take information from one worksheet and link it to another sheet, therefore only having to enter it the one time.
- Update information on the source worksheet and it will automatically update the information in the linked cells on the linked worksheets.

This feature is handy, saves keystrokes and prevents the errors. The worksheet page that you wish to link to another page is called the **source worksheet**. The worksheet that the information is to be linked to, is referred to as the **target worksheet**.
**Linking Information between Worksheets in a Single Workbook**

To link between two open worksheets, do the following:

1. Select the cell(s) of information in the source worksheet you want to link to the target worksheet.
2. Right-click on the selected cell(s) and select **Copy** from the menu.
3. Go to the target worksheet.
4. Select the cell or range on the target worksheet that you want to link the information.
5. Right-click on the range and select **Paste Special**.

![Paste Special Dialog Box]

6. Select the **Paste Link** button at the bottom left corner.

Excel pastes the information into the sheet you selected and has linked the two cells. On the target worksheet the link formula can be seen in the formula bar as long as the linked cell is selected as your active cell (see Figure 2).
Linking Information between Open Workbooks

Linking can also be used between two open workbooks. To link information between two open workbooks, do the following:

1. Select the information in the workbook you want to copy and link to the target workbook.
2. Right-click on the cell(s) and select **Copy**.
3. Activate the second workbook by clicking on it.
4. Select the target sheet.
5. Select the range you want to paste the information into.
6. Right-click on the selected range and select **Paste Special**.
7. Excel displays the **Paste Special** dialog box (see Figure 3). Select the **Paste** link.

**Tips**

- Use **Ctrl F6** to toggle between the open windows **OR**
- Select **View > Arrange All** from the **Ribbon**.
- Select **Tiled**, and then **OK**. This will allow you to view all open workbooks at the same time.
- To close all files, hold the **Shift** key while selecting the **File** menu and choose close all.
**Moving Links between Workbooks**

You can remove or freeze the information in the target area by converting the linked information to values that do not change.

To remove the link, do the following:

1. Select the linked information in the target sheet.

2. Right-click on the selected information and select **Copy**. Excel will copy the linked information to the Windows clipboard.

3. In the **Paste Special** box, select **Values** (see Figure 3).

4. Select the **OK** button.
**TRAINING AND SUPPORT**

**IT Training**

**Contact Us:**
IT Training & Development  
Phone: (818) 677-1700 or x1700 (on campus)  
Email: training@csun.edu

**Troubleshooting and Support**  
If you experience problems getting started with Office 2007 contact the Help Center at x1400 or helpcenter@csun.edu.