
Exercise #5C  

Image 
Classification 

(Evaluating 
Signatures) 

 

Objective  

• Examine the signatures of different land cover 
• Learn how to evaluate these.  

 

Once signatures have been defined and saved in a signature file they can be evaluated, 
deleted, renamed and merged with signatures from other files.  You can use signatures 
defined from one image to classify a different image.  You can merge parametric and 
non-parametric signatures, and signatures that are defined from supervised and 
unsupervised training sites. 

In this set of exercise you will learn the tools for looking in detail at the spectral 
signatures you have defined, and for evaluating the signatures.  The steps we will go 
through allow you to look at the statistics of the signatures and the areas in the image 
which fall within the signature definitions – but they do not do the actual 
classification.  This will require us to choose the decision rules to apply in allocating 
pixels to classes, and will be done later. 

1.  Alarm 

Alarm gives you quick look at which pixels in the image fall within your signature 
definitions using the parallelepiped rule (i.e. those pixels in the image which have 
intensity values in each band between the minimum and maximum values, or the 
mean ± some number of standard deviations, used in the signature definition for that 
class). 



Open the image (los_angeles_subset.img or <yourfile_subset>.img) in the Viewer.  
Open the Signature Editor.  Open one of your signature files for this image (eg. 
los_angeles_subset_aoi.sig or <yourfile_subset_aoi>.sig).  Select one of the signatures 
(eg. grass).  Select View -> Image Alarm from the Signature Editor menu bar.  Select 
Set Parallelpiped Limits.  You can change the boundaries of the spectral defining box 
to the maximum and minimum used in the training sample, or some # of standard 
deviations from the mean value.  Close this dialog. Click OK.  The alarmed pixels will 
be highlighted in yellow (or other signature color).  Now investigate how the 
highlighted areas change when you change the definition of the parallelepiped. 

In the screen dump below, 3 alarm masks are shown using 3 different definitions of 
the parallelepiped.  If you increase its size, more pixels fall into the definition for that 
signature.  The aim is to define the signature and decision rule so that exactly the right 
amount of land falls into this category. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Parallelepiped limits are set to 
2 standard deviations within the 
mean. 

Parallelepiped limits are set 
to 1 standard deviation 
within the mean. 

Parallelepiped limits are 
set to the minimum and 
maximum values. 



1.1  Turn in a screen dump similar to the one displayed above, showing part of 
your image with three different settings for the limits on one of the land covers. 
(The example above shows the limits for forest_1.) (Set your limits to max and 
min, 1 standard deviation, and 2 standard deviations as above).  Label each 
appropriately.  Explain your observations – which definition puts most pixels 
into the class you have chosen (and why)? 
 
2.  View signatures in feature space (ellipses) 
 
Draw ellipses showing the signature mean ± some number of standard deviations, or 
the minimum and maximum limits, in feature space.  This will show which signatures 
have a lot of overlap and which are well separated.  It is also useful for gauging the 
number of standard deviations which should be applied in the classification decision.  
(You want the signatures to cover as much of the feature space as possible, without 
overlapping.) 
 
Open the image (los_angeles_subset.img or <yourfile_subset>.img) in Viewer1, and 
one of the feature spaces, e.g. bands 2 and 4 (los_angeles_subset_2_4.fsp.img), in 
Viewer2.  Open your signature file.  In the Signature Editor menu bar choose Feature 
-> Objects.  Enter 2 for the Viewer number (corresponding to Viewer used for the 
Feature Space image).  Enter the number of standard deviations from the mean you 
wish the ellipses to encompass.  Label the ellipses.  Select all the signatures in the 
Signature Editor.  Click OK in the Objects dialog.  Experiment with different numbers 
of standard deviations and see how the sizes and shapes of the ellipses change.  View 
the ellipses in other feature spaces (i.e. using other band combinations).  You should 
be able to see which signatures are well-separated, which are not very well 
differentiated, and which bands differentiate the signatures best. 
 
Turn in a screen dump similar to the one displayed below, showing the same part 
of your image with a setting of 1 standard deviation for the signature limits, and 
showing the ellipses drawn in feature space for all of the signatures.  Use feature 
space for bands 2 and 4.   
2.1. Which of the land covers show a large amount of overlap? 
2.2. Which are well-separated?   
2.3. Would you expect this to be the case in different spectral bands? 
2.4. How do your ellipses change when you increase the signature definition to 
include 3 standard deviations? 
 



 
 
3.  Contingency matrix 
 
Use a contingency matrix to find out how many of the pixels used in the training 
sample for each class will end up being classified into that class according to the 
decision rule that you choose.  If the spectral signatures of two different classes are 
quite similar then outlying pixels in the training sample used to define one signature 
class may actually be closer (spectrally) to the mean of a different class.  Then if the 
minimum distance decision rule was used to put pixels into classes these outliers 
might wind up being classified differently.  The contingency matrix tests this. 
 
Open the image (los_angeles_subset.img or <yourfile_subset>.img) in Viewer1.  
Open the signature file.  In the Signature Editor select all the signatures.  In the menu 
bar select Evaluate -> Contingency.  Choose the minimum distance or maximum 
likelihood rule and click OK.  Print out or save the report. 

Feature 
and 5. 



 
 Reference Data 

 
Classified 

Data 
agricultural 

field 1 
forest_1 agricultural 

field 2 
forest_2 water Row Total 

 
agricultural 

field 1 
170 0 0 6 0 176 

forest_1 
 

0 414 0 405 0 819 

agricultural 
field 2 

0 0 466 0 0 466 

forest_2 
 

0 30 0 5050 0 5080 

water 
 

0 0 0 1 574 575 

Column Total 
 

170 444 466 5462 574 7116 

 
The contingency matrix above shows that of 176 pixels classified by the chosen 
decision rule to be agricultural field_1, 170 were from the original training sample 
used for this class, and 6 were from the training sample used for forest_2. 
All the training sample for water was classified as water, but so was one other pixel 
that came from the forest_2 training sample. 
 
3.1 In the table shown above, how many pixels were classified as water? 
3.2 How many of these came from the original AOI used to define the water 
signature?   
3.3 How many came from some other signature definition?  Which signature was 
this?   
3.4 What two classifications are most confused?   
3.5 Why do you think this is? 
 
Now print out and turn in your own table.  Choosing water (if it is defined for 
your image) or some other class (if water is not defined), answer the same 
questions posed above. 
 
 
4.  Separability 
 
This is a measure of the spectral distance between two signatures, and helps you to 
decide how different the signatures are.  There are several ways of defining 
“distance”.  The simplest is the Euclidean distance, which is the square root of the 
sum of the squares of the distances between each pair of band mean values.  (Note this 



is the same way that we find the distance between 2 points on a graph in 2-
dimensions, or between 2 points in space in 3-dimensions.  In this case we are just 
extending that definition to the n-dimensions of n bands, and are using spectral space 
rather than spatial space.)  Some of the other definitions of distance which can be used 
incorporate the covariances of the signatures as well as their means.  (These formulas 
include ⎯ Divergence, Transformed Divergence and Jeffries-Matusita Distance.) 
 
Open the signature file.  In the Signature Editor, select all the signatures.  Then choose 
Evaluate -> Separability from the menu bar.  In the dialog pick Euclidean distance.  
Leave Layers per Combination at 6.  Choose a Summary Report and click OK.  Print 
out and/or Save the Report. 
 
Signature Separability Listing 
 
    File: c:/documents/helen/remote sensing 
images/imagine_examples/germtm_aoi_sig.sig 
 
    Distance measure: Euclidean Distance 
 
    Using bands: 1 2 3 4 5 6  
 
    Taken 6 at a time 
 
       Class 
 
   1   agricultural field_1                                     
   2   forest_1                                                 
   3   agricultural field_2                                     
   4   forest_2                                                 
   5   water                                                    
 
 
                           Best Minimum Separability 
 
   Bands              AVE    MIN    Class Pairs: 
                                     1: 2   1: 3   1: 4   1: 5   2: 3   2: 4   
2: 5   3: 4   3: 5   4: 5 
  1  2  3  4  5  6    115     21      79     74     76     149    140     21   
133    144    220    112 
 
 
                           Best Average Separability 
 
   Bands             AVE    MIN    Class Pairs: 
                                    1: 2   1: 3   1: 4   1: 5   2: 3   2: 4   
2: 5   3: 4   3: 5   4: 5 
  1  2  3  4  5  6   115     21      79     74     76    149    140     21     
133    144    220    112 
 
This report shows that the average Euclidean distance between the signatures (using 
all 6 bands in the signature definition) is 115.  The minimum distance between any 



two signatures is 21.  This is between classes 2 and 4.  In the signature file used here, 
these classes correspond to forest_1 and forest_2. 
 
4.1  Which two classes are most distinct? 
4.2  What units are used for these distances?  (Think carefully about how these 
distances are defined.) 
4.3  Turn in the separability report for your signatures.  In your report, which 
two of your classes are most distinct? 
 
Perform a new separability using only 3 Layers per Combination.  This means that 
only 3 bands at a time will be used in the signature definitions.  Now instead of 
calculating the Euclidean distance over 6-dimensional space, it will be calculated over 
3-dimensions.  The computer performs the computation using every possible set of 
three bands.  It prints a report on the three bands giving the Best Minimum 
Separability and the Best Average Separability.  This will help you make a decision 
about displaying and classifying an image if you only want to use three bands and 
want to do the best job of distinguishing between all the land cover types. 
 
Signature Separability Listing 
 
    File: c:/documents/helen/remote sensing 
images/imagine_examples/germtm_aoi_sig.sig 
 
    Distance measure: Euclidean Distance 
 
    Using bands: 1 2 3 4 5 6  
 
    Taken 3 at a time 
 
       Class 
 
   1   agricultural field_1                                     
   2   forest_1                                                 
   3   agricultural field_2                                     
   4   forest_2                                                 
   5   water                                                    
 
 
 
                           Best Minimum Separability 
 
   Bands         AVE    MIN    Class Pairs: 
                               1: 2   1: 3   1: 4   1: 5   2: 3   2: 4   2: 5  
3: 4   3: 5   4: 5 
 4  5  6        105     21      63     70     58    140   121     21     132  
124    207    112 
                                 
 
                           Best Average Separability 
 



   Bands         AVE    MIN    Class Pairs: 
                               1: 2   1: 3   1: 4   1: 5   2: 3   2: 4   2: 5  
3: 4   3: 5   4: 5 
 3  4  5        105     21      70     65     66    140    121     21    131   
124    202    111 
                                 

 
 
When considering only three bands in the classification, the report above shows that 
for the signatures used in this classification we could choose either bands 4, 5 and 6 
⎯ which produce the best (i.e. largest) minimum separation between signatures, or 
bands 3, 4 and 5 ⎯ which produce the best average over all the signatures.  You can 
see in the report above that there is very little difference between the separation of the 
signatures whichever of these two sets of bands we choose. 
 
4.4  Print out and turn in a separability report for your signatures based on three 
bands.  Which three bands produce the best minimum separation between 
signatures, and which produce the best average separation? 
4.5  Print out and turn in a separability report for your signatures based on two 
bands.  Which two bands produce the best minimum separation between 
signatures, and which produce the best average separation?   
 
5.  Histograms 
 
You can also check on the difference between the signature definitions (or the spectral 
signatures of the pixels that were used to defined the signatures in the file) by viewing 
their histograms.  Each histogram shows the number of pixels of a given brightness 
(intensity) in some band.  You can choose to look at one signature at a time, or view 
them all together. 
 
In the Signature Editor select all the signatures.  In the menu bar select View -> 
Histograms.  In the dialog box, select All Selected Signatures (to plot the histograms 
of all the signatures together).  Select a single band, or all bands.  Click on Plot. 
 



 
 
This screen dump shows the histograms for all the bands.  
  
5.1  Turn in a screen dump for your signature histograms similar to that shown 
above.   
5.2  In the one shown above, in which band are water and forest_2 most difficult 
to distinguish?  
5.3  In which band are they most distinguishable?   
5.4  What parts of the spectrum do these bands correspond to?   
5.5  In your signature definitions, which bands do the best job of separating 
water from other land covers?   
5.6  Which bands are the worst for this? 
 
6.  Statistics 
 
A parametric signature is based on the statistics of the pixels which went into its 
definition ⎯ i.e. the mean and standard deviations of the intensity values in each band 
for each pixel used.  The signature file stores these statistics: 

• the number of bands in the input image 



• the minimum and maximum value in each band for each cluster used in the 
definition 

• the mean intensity in each band for the pixels in the cluster 
• the covariance matrix for each cluster 
• the number of pixels in each cluster 

You can view these statistics to make judgments about the signatures and their 
differences. 
 
In the Signature Editor choose View -> Statistics.  You will see the statistics for the 
signature selected. 
Or you can print a statistics report.  Choose File -> Report -> Check the Statistics box 
and the All Signatures box.  The report will appear on the screen.  Print it from the 
File menu. 
 

Number of layers: 6 
 
Signature: agricultural field_1 
Number of pixels: 170 
                                  Statistics 
Layer  Mimimum    Maximum       Mean      Sigma 
  1    124.000    137.000    131.382      2.146 
  2     52.000     61.000     57.365      1.746 
  3     67.000     88.000     81.324      4.299 
  4     93.000    115.000    101.459      3.067 
  5    108.000    152.000    123.306      8.464 
  6     41.000     62.000     48.953      3.581 
 
                                  Covariance 
Layer        1          2          3          4          5          6 
  1      4.604      2.576      6.568     -1.526     -5.212     -1.834 
  2      2.576      3.050      6.503     -1.222     -5.053     -1.829 
  3      6.568      6.503     18.481     -3.777    -12.058     -4.807 
  4     -1.526     -1.222     -3.777      9.410     11.492      3.608 
  5     -5.212     -5.053    -12.058     11.492     71.634     27.926 
  6     -1.834     -1.829     -4.807      3.608     27.926     12.826 
 
 
 
Signature: forest_1 
Number of pixels: 444 
                                  Statistics 
Layer  Mimimum    Maximum       Mean      Sigma 
  1    108.000    119.000    112.926      1.381 
  2     40.000     47.000     43.045      1.263 
  3     37.000     45.000     40.047      1.486 
  4    122.000    158.000    141.108      6.963 
  5     68.000    107.000     82.423      6.519 
  6     17.000     32.000     21.615      2.641 
 
                                  Covariance 
Layer        1          2          3          4          5          6 



  1      1.906      0.565      0.656      0.245      3.311      1.154 
  2      0.565      1.596      1.226     -1.499      5.024      1.963 
  3      0.656      1.226      2.208     -0.962      6.490      2.603 
  4      0.245     -1.499     -0.962     48.489      8.647      0.437 
  5      3.311      5.024      6.490      8.647     42.493     15.407 
  6      1.154      1.963      2.603      0.437     15.407      6.973 
 
 
 
Signature: agricultural field_2 
Number of pixels: 466 
                                  Statistics 
Layer  Mimimum    Maximum       Mean      Sigma 
  1    135.000    157.000    142.418      3.268 
  2     59.000     75.000     65.948      2.633 
  3     86.000    118.000    100.818      5.550 
  4    103.000    130.000    115.453      5.315 
  5    157.000    209.000    183.792      8.405 
  6     68.000     95.000     81.693      5.513 
 
                                  Covariance 
Layer        1          2          3          4          5          6 
  1     10.678      7.348     15.657     11.651     10.397      3.247 
  2      7.348      6.931     13.513     10.539      9.680      3.083 
  3     15.657     13.513     30.799     23.399     21.945      5.907 
  4     11.651     10.539     23.399     28.244     12.869     -3.912 
  5     10.397      9.680     21.945     12.869     70.651     37.824 
  6      3.247      3.083      5.907     -3.912     37.824     30.398 
 
 
 
Signature: forest_2 
Number of pixels: 5462 
                                  Statistics 
Layer  Mimimum    Maximum       Mean      Sigma 
  1    107.000    121.000    112.531      1.384 
  2     39.000     49.000     41.909      0.888 
  3     35.000     58.000     39.237      1.253 
  4     47.000    161.000    121.109      9.257 
  5     23.000    122.000     76.291      6.067 
  6      6.000     62.000     20.248      2.069 
 
                                  Covariance 
Layer        1          2          3          4          5          6 
  1      1.915      0.316      0.514      0.892      1.007      0.628 
  2      0.316      0.789      0.504      0.874      1.750      0.763 
  3      0.514      0.504      1.571     -1.120      2.136      1.311 
  4      0.892      0.874     -1.120     85.694     34.176      4.738 
  5      1.007      1.750      2.136     34.176     36.804      9.174 
  6      0.628      0.763      1.311      4.738      9.174      4.283 
 
 
 
Signature: water 
Number of pixels: 574 
                                  Statistics 
Layer  Mimimum    Maximum       Mean      Sigma 



  1    109.000    118.000    113.648      1.473 
  2     38.000     42.000     39.852      0.609 
  3     34.000     39.000     36.887      1.070 
  4     25.000     53.000     30.610      3.044 
  5      6.000     36.000     11.608      3.218 
  6      1.000     12.000      3.979      1.417 
 
                                  Covariance 
Layer        1          2          3          4          5          6 
  1      2.169      0.140      0.377     -0.502     -0.082     -0.006 
  2      0.140      0.371      0.142      0.218      0.396      0.152 
  3      0.377      0.142      1.144      0.097      0.617      0.218 
  4     -0.502      0.218      0.097      9.265      7.215      2.301 
  5     -0.082      0.396      0.617      7.215     10.357      3.165 
  6     -0.006      0.152      0.218      2.301      3.165      2.007 

 
This report shows the minimum, maximum, mean and standard deviation (sigma) for 
all the pixels used to define each of the signatures in each of the bands.  For example, 
for the water signature above, it is darkest in band 6 with a mean intensity of less than 
4.  It shows least variability in band 2 (the sigma is only 0.609) and the highest 
reflectance in band 1. 
 
6.1 Print out and turn in a statistics report for your signatures.    
6.2  In the report above the highest reflectance for water is in band 1 - what color 
is this?  Is that what you would expect?   
6.3  In which part of the spectrum does water absorb light most effectively (i.e. 
reflect the least)?  Does this agree with your own definition? 
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