How to Do Audio Stuff in DP (v. SD-S07)
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The Unbearable Slowness of Zip disks and flash drives

Remember that zip disks and flash drives are too slow for audio and you will need to
copy your project to the hard drive, eject your zip disk, work on the project, and then
copy it back to the zip disk at the end of a work session:

* Make sure that you have quit Digital Performer, drag the entire project folder
(that includes both the sequencer document and the Audio Files folder) to the
Documents folder of the mtl_student account on the hard drive (there’s an alias to
that location in the dock), eject your zip or flash drive, and work on the hard drive
copy of your project.

*  When you're done working at a computer for the day, insert your Zip disk or flash
drive and copy your project from the Documents folder to the Zip or flash drive
for backup. If you leave your project only on a lab computer, it could very well
get erased.

Setting Up

OPENING A FILE. Once you’ve launched Digital Performer, choose

File-> New—> New (this means click on the file menu, move the arrow to “New” and
then over to “New” in the submenu; this convention will be used throughout this
guide) to create a new sequence file or File=> Open to open an existing file. Two
windows open automatically: the Control Bar and the Tracks window for the current
sequence. You can actually have many different sequences in a file, but for now we’ll
stick to one.

THE CONTROL BAR. The top of the bar contains the transport controls, the clock,
and the metronome settings. The bottom strip contains recording mode options such
as metronome click, countoff, overdub, etc.
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* EDITOR BUTTONS. The windows in digital performer that allow you to alter the
information that you record are called editors. If the editors palette shown below
doesn’t appear, click once on the triangle at the upper right of the control bar to get to
the editor buttons palette (use flyover help to find out what each icon means):
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* THE TRACKS WINDOW. The left side of the tracks window contains specifications
for each track including record-enable status, play status, track name, output
destination, default patch, automation status, and comments. The right side contains
an overview of information in the tracks with a time ruler across the top.
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* ADDING TRACKS. The default DP file has several MIDI tracks (note icon), several
audio tracks (wavy icons), and a conductor track (theoretically a conductor icon) that
contains tempo, time signature, key signature, and marker information. You can
immediately delete the MIDI tracks by clicking on the track name (or dragging down
the track names to select multiple tracks and choosing Project-> Delete Tracks. To
add additional audio tracks, choose Project> Add Track—=> Mono Audio Track (or
stereo if the audio files will be stereo).

* NAME THE TRACKS. For each track, option-click in the “track name” column, type

an appropriate name, and hit enter. Ignore the “Conductor” track for now.
OUTPUT TRACK NAME DEFAULT PATCH
ductor
Proteus FX-1 Melodgl I
Proteus FX-2 ) Track-k
Proteus FX-3 ) Track-3
Proteus F¥-4 ) Track-4
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Time Formats

Digital Performer allows you to use either musical time (measures, beats, etc.) or clock
time (either SMPTE time or regular time). To change to frame-time (SMPTE format
measured in hours:minutes:seconds:frames), click the button next to the main clock until
the film icon appears as below.
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For the editors, time type is controlled by the Time Formats window (choose

Setup-> Time Formats). In this window, you can change the time type for time rulers,
pointer coordinates, and event information. To choose frame time (which you will use
almost exclusively in this class), click on the “Frames” radio button at the top of the
window. Notice that the time ruler of the tracks window now shows
hours:minutes:seconds.
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Playback: Mute, Solo, Loop

* RECORD-ENABLE. You record-enable a track by clicking on the icon in the “rec”
column for the desired track.

* MUTE. You can disable playback on a track (“muting” a channel in traditional audio
terms) by clicking on its “play” arrow —the normally blue arrow will become gray.
This is valuable if you need to hear a mix without certain elements.

* SOLO. Solo works in the opposite way. Click the solo button at the top of the
window, all the play buttons will turn orange. Click on the play buttons that you wish
to hear and all the others will be muted. Multiple tracks can be soloed at one time.
This method of soloing allows you to switch quickly between a set of soloed tracks
and full playback. Soloing can also be used in the graphic, list, or notation editors to
solo only the information in the track shown in that window.

* LOOP. To cause part of a track to repeat some number of times, use the loop feature
(this is different than the memory-cycle recording mode). Select the information that
you wish to loop either by clicking on a block when your cursor looks like an arrow,
or by drag-enclosing information when your cursor looks like a crosshair (see below
for details on information selection). Choose Region—> Set Loop, make sure that the
loop time is correct, and select the number of times that the information should be
looped. A gray bar will show up in the track for the looped duration.

3 Audio in DP (v. S07)



Importing Audio

Put Audio in Audio Files Folder

Create a new project, or if you’re adding to an old project duplicate your project
folder in the Finder by double-clicking on your zip disk, then clicking (not
double-clicking) on your project folder, and then choosing File=> Duplicate (or
38-D). You should now have a folder with your project file and an Audio Files
folder inside. If you don’t, make one!

8eese "~ New File Project =
o =] |
= _ =S % {E:' »
Back Forward View Computer Home

2 items, 1.67 GE available

-

Audio Files MNew File

To use audio files from the 496H Resources folder on the server: click on the
Music_Lab_Server icon in the dock, double-click on the 496H_Resources folder,
and double-click on the appropriate audio folder. Drag the file(s) from the server
to the Audio Files folder in your project folder on your Zip disk or the hard drive
(do not attempt to “work from the server”). Drag the server icon to the trash icon
in the dock after you’ve dragged the files to your Zip disk. Always put audio files
in the “Audio Files” folder inside your project folder:
806 [ Audio Files =
= 2z = 'm) ;&_3. «’j‘_\ »|
Back Forward View Computer Home |
10 items, 1.67 GE available
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! New File
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To use audio files from another source: drag those audio files into the “Audio
Files” folder of your project folder.

To use audio from a CD: launch your DP project, open the soundbites window
(Project-> Soundbites), choose “Import Audio...” from the mini-menu, navigate
to the CD, and choose the desired track (or part of a track). If you import audio
from a CD, you don’t have to go through the next step to “Associate” the CD
audio with the project—it already appears in the soundbites window.

“Associate” the audio with your project

Open the Soundbites window (Project-> Soundbites)
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Drag the files from your zip disk or hard drive onto the soundbites window (you
can also choose “Add Soundbite...” from the mini-menu of the soundbites
window to do the same thing). You’re not actually moving the audio anywhere;
you’re just telling DP that this audio belongs to the project.
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What you see in the soundbites window are now called —oddly enough —
“soundbites.” There is logic to not calling them “audio files,” because you will
not be changing or moving the original audio file, just a reference to it.
To listen to a soundbite in the soundbites window, make sure that the speaker icon
in the titlebar is active (yellow) and click on the name of the soundbite:
TB$[Y R 1 D€ Soundbites
List  Info  Edit |
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Remember that the zip or flash drive will likely be too slow for this purpose, so
you may have to quit DP, copy your entire project folder to the Documents folder
of the MTL_Student account on the hard drive, eject your zip disk or flash drive,
and work from the hard drive. At the end of a work session you will copy the file
from the documents folder to your zip or flash drive.

Create an Audio Track(s)

Choose Project-> Add Track—-> Mono Audio Track or - Stereo Audio Track
to create a track for the audio. You can tell if a file is stereo or mono by looking at
the “wavy” icon next to the file name in the soundbites window (one wave means
mono, two means stereo—the soundbites in the example above are all mono).
You can move these tracks vertically in the tracks window by dragging their
handles in the “Mve” column.

Once you’ve added a track, you must assign it to an output. Click in the output
column and choose "built-in 1-2". If that is not available, choose “New Stereo
Bundle” and then "built-in 1-2".
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Place a soundbite into the sequence

* Drag a soundbite from the Soundbites window to a mono or stereo audio track in the
tracks editor by dragging the "Mve" handle of the soundbite (the wavy line). The blue
outline will guide the placement of the soundbite. DP will follow column-snapping
conventions and place the soundbite right on a column. If it won’t let you drop the

file then you may be trying to place a stereo file in a mono track or vice versa.
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*  You can also open the sequence editor for an audio track (by double-clicking on the
track name) and drag a soundbite to the sequence editor. Here the Edit resolution will
control the placement (see below).

-+

Editing Audio in the Sequence Editor

Moving, Copying, Cutting, Pasting, Snipping, and Splicing
* All actions in the Sequence Editor, including selecting audio and moving audio, are
governed by the “Edit Resolution”. This causes all actions to snap to a grid. You will

usually want to disable this, by clicking on the box next to the word “unit” to turn it
off (not blue):
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*  You can move a soundbite by selecting the soundbite when the cursor looks like an
arrow and then, with the cursor now looking like a finger icon, dragging it
somewhere, perhaps even to a new track

*  You can make a “copy” of a soundbite by selecting the soundbite and holding down
the option key. Then, with the cursor looking like a two-finger icon, drag to the
desired location and release. New audio is not actually creating by this "copying," the
same audio file is just referenced again.

*  You can also select part of a soundbite by holding your mouse over the bottom part
of the soundbite until it looks like a cross-hair and dragging. Once selected, you can
perform the various editing functions on that segment such as choosing copy, cut, or
trim (this last one removes the part of the soundbite that is not selected) from the Edit
menu. You can paste this copied or cut segment elsewhere by selected part of the
target area and choosing paste from the Edit menu.

e “Cut” removes a soundbite (or part of a soundbite) leaving the remaining material in
place. “Snip” (also in the Edit menu) removes the material and also removes the time.
Similarly, “Paste” places the clipboard material over existing material, whereas
“Splice” inserts the material (just like real tape!)
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To change just the edge of the soundbite hold your cursor near the edge of the
soundbite until it turns into two facing arrows and drag (don’t drag when the cursor
looks like a hand —this will timestretch the audio)

When edge editing the audio, you will usually want to have “Edge Edit Copy”
selected in the mini-menu of the sequence editor. This function creates a new
soundbite (not new audio) every time you move the edge. Otherwise, edge editing
changes all copies of a soundbite.

Selecting and Editing—Watch the Changing Cursor!

Arrow —click soundbite to select

Finger (shows up when something has been selected) —drag soundbite to move
Double-finger (shows up when option key is held down)—drag to copy
Cross-hair (within the soundbite near bottom)—drag to select time

o To getrid of anything not selected, choose Edit=> Trim

Double-arrow (at edge of soundbite) —drag to edit edge

o Be sure that “Edge Edit Copy” is checked in the sequence editor mini-menu
TR T &S D

Sequences | 2 ‘
— 1
Zoom | 3 |
_g Goto Counter
@ Gato...
"
— Set Ramp Dengity
Lr Clear Default Patch
L5 MIDI Edit
4 Switches Are Cont. Data i
HA Snap To Markers I
3 Show Marker Crid Lines

|

B Show Edit Grid Lines

Bi v Shade Notes Using Velacity

_-J Show Notes When Scrolled Offscreen '

o~ Show Times »
« Edge Edit Copy

Crossed lines (at edge of soundbite near top) —drag to create a fade
Sideways Hand (at top edge of soundbite) —drag to time-stretch

Fade in/out and Crossfade

When you edge-edit or trim audio, you may end up with edges that do not start at
silence. This can create annoying and unprofessional pops or clicks.

To fix this, move your mouse at the edge of the soundbite near the top until the cursor
turns into two crossed lines (there’s a little “handle” there) and drag a little bit into the
soundbite. This will create a fade in or out depending on which end of the sound bite
your mouse is. In this picture there is both a fade in and a fade out indicated by the

red lines:
—
| |

I
You can “cross-fade” two sound bites by overlapping them, moving the mouse to the
bottom of the soundbites until the cursor looks like a cross hair, dragging across the
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end of the first soundbite and the beginning of the second, and then choosing
Audio-> Fades...

JAMMY 1. aif JAMMY 1 aif. 7

You can control the shape the fades by choosing Audio=> Fades... and choosing a
different shape:

Pan and Volume Settings in the Sequence Editor

Before you add pan or volume, first make sure that automation is play-enabled by
clicking on the downward arrow next to each track and selecting automation—>play
from the pop-up menu or by clicking on the arrow in the mixer window.
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Automation Play

In the Sequence editor, click on the pop-up menu next to the desired track that
initially reads "soundbites" and choose “Pan” or “Volume”. If that pop-up menu
doesn’t show, you may need to make the track larger by clicking on the downward
arrow and choosing size>medium

From the “tools” palette (if they’re not onscreen, choose Studio=> Tools) select the
line type (for example, straight line), choose the pencil tool, and draw the desired
shape.
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Once you’ve inserted a line, you can choose the arrow tool, click on the line, and drag
one of the line points to create the pan or volume shape that you desire. If the edit
resolution is on, you will only be able to create breakpoints at edit resolution
boundaries. (If your volume or pan line is dashed, then you need to enable automation
playback).

Pitch-Shift, Time Stretch, Reverse, and Effects

Pitch-shift a soundbite by selecting the soundbite and choosing Region—> Transpose
and then selecting two pitches whose interval represents the desired pitch shift (C3 to
C4 is a lot, C3 to C#3 is a little).

Pitch shifting noisy sounds can generate odd results sometimes. If you’re getting
strange results, try the “Standard” mode of pitch shifting (as opposed to the default
“PureDSP” mode.

o Open the soundbites window and click on the “info” pane

T BSOS 100

Lis # tnto | eat | SourdFile
o infof .

A BOSEN mf ACW Sa

o Select “Use Standard Pitch Shift” from the transpose pop-up menu
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* Time Stretch or Compress a soundbite by holding the mouse over the upper edge of
the soundbite so that it looks like a sideways hand and dragging. Time stretching or
compressing too far can lead to audio that sounds overly “electronic”.

* You can reverse a soundbite by selecting it (or part of it) and choosing Audio-> Plug-
ins> Reverse.

*  You can apply plug-ins or “spectral effects” in the Sequence Editor by selecting the
soundbite and choosing Audio=> Plug-ins=> and then whatever you want. Try the
“presets” in the effect window’s mini-menu and use the “preview” feature to see what
the effect sounds like before you apply it.

* NOTE: Applying plug-ins in the sequence editor automatically creates new audio.
You should use the sequence editor if you want to change one sound in a track by
itself. If you want to apply an effect continuously, then you should apply it as a plug-
in in the Mixer window (possibly with automation).

Bouncing to Disk

To turn audio tracks into an mp3 (or into a WAV or AIFF file suitable for burning to

CD):

When you have more than one audio track you need to “bounce” all of the audio to one

audio file.

* First, make sure that you’re hearing what you want to hear (make sure that none of
your elements are muted).

* In the tracks editor (or sequence editor) select the information that you want to
bounce (you could just do a select all by choosing command-A). Only audio that can
be heard will be bounced.

* Choose Audio-> Bounce to Disk, make the following settings (for an mp3). Be sure
that you name the file in an informative way and that the Destination Folder is your
project folder on the hard drive, and click OK

Format: LAM.E. Audio Export MP3 2]

Sowrce: Built-in Audic 1-2 2

File Name: |Hosken_ Frojectl

[ Save Settings for Bounce Again
[ Save Settings as Audic Export Format

Destination Folder: ” Choose

Hosken_data/ Documents (CSUMN) CSUMN-Classes |
Music 1050L/ Podcast_Sessions Project) Audio Files/
Hoskan_Projectl

ok ) [ concel ]

* Next you’ll get this window. Make the following settings, and click OK.
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Using the L.AM.E. Encoding Engine

Channals: | Auto ]
Stereo Mode: | loint Stereo [ |
Output Sample Rate: | Auto A
Encode Quality: | standard ]
Encoding Mode: | Constant Bit Rate |
Bit Rate: | 128 kbps iStandard) 3
3 Fitter Frequencies Below 10 hz

* Be sure to listen to the resultant MP3 before you turn it in.

11 Audio in DP (v. S07)



